libsrsirc-0.0.14.ebuild 542 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A lightweight, cross-platform IRC library"
  5. HOMEPAGE="https://github.com/fstd/libsrsirc"
  6. SRC_URI="http://penenen.de/${P}.tar.gz"
  7. LICENSE="BSD"
  8. SLOT="0"
  9. KEYWORDS="~x86 ~amd64"
  10. IUSE="static-libs ssl"
  11. DEPEND="
  12. ssl? ( dev-libs/openssl:0= )"
  13. RDEPEND="${DEPEND}"
  14. src_configure() {
  15. econf \
  16. $(use_enable static-libs static) \
  17. $(use_with ssl)
  18. }
  19. src_install() {
  20. default
  21. find "${D}" -name '*.la' -delete || die
  22. }