libtorrent-0.13.6.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils libtool toolchain-funcs
  5. DESCRIPTION="BitTorrent library written in C++ for *nix"
  6. HOMEPAGE="https://rakshasa.github.io/rtorrent/"
  7. SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. # The README says that the library ABI is not yet stable and dependencies on
  10. # the library should be an explicit, syncronized version until the library
  11. # has had more time to mature. Until it matures we should not include a soname
  12. # subslot.
  13. SLOT="0"
  14. KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
  15. IUSE="debug ipv6 libressl ssl test"
  16. RDEPEND="
  17. sys-libs/zlib
  18. >=dev-libs/libsigc++-2.2.2:2
  19. ssl? (
  20. !libressl? ( dev-libs/openssl:0= )
  21. libressl? ( dev-libs/libressl:= )
  22. )"
  23. DEPEND="${RDEPEND}
  24. virtual/pkgconfig
  25. test? ( dev-util/cppunit )"
  26. src_prepare() {
  27. elibtoolize
  28. }
  29. src_configure() {
  30. # configure needs bash or script bombs out on some null shift, bug #291229
  31. CONFIG_SHELL=${BASH} econf \
  32. --enable-aligned \
  33. $(use_enable debug) \
  34. $(use_enable ipv6) \
  35. $(use_enable ssl openssl) \
  36. --with-posix-fallocate
  37. }
  38. src_install() {
  39. default
  40. prune_libtool_files --all
  41. }