libupnp-1.8.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils flag-o-matic autotools vcs-snapshot
  5. DESCRIPTION="An Portable Open Source UPnP Development Kit"
  6. HOMEPAGE="http://pupnp.sourceforge.net/"
  7. SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="1.8"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
  11. IUSE="debug doc ipv6 static-libs"
  12. DOCS="NEWS README.md ChangeLog"
  13. PATCHES=(
  14. "${FILESDIR}"/${PN}-1.8.0-docs-install.patch
  15. "${FILESDIR}"/${PN}-1.6.21-cflags.patch
  16. )
  17. src_prepare() {
  18. default
  19. # fix tests
  20. chmod +x ixml/test/test_document.sh || die
  21. eautoreconf
  22. }
  23. src_configure() {
  24. use x86-fbsd && append-flags -O1
  25. # w/o docdir to avoid sandbox violations
  26. econf \
  27. $(use_enable debug) \
  28. $(use_enable ipv6) \
  29. $(use_enable static-libs static) \
  30. $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
  31. }
  32. src_install () {
  33. default
  34. dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}-1.8
  35. use static-libs || prune_libtool_files
  36. }