12345678910111213141516171819202122232425 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit cmake-multilib
- DESCRIPTION="A library passing all socket communications through unix sockets"
- HOMEPAGE="https://cwrap.org/socket_wrapper.html"
- SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
- IUSE="test"
- DEPEND=""
- RDEPEND="${DEPEND}"
- # Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
- # Because of this we cannot use cmake-multilib_src_configure() here.
- multilib_src_configure() {
- local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
- cmake-utils_src_configure
- }
|