stem-1.4.0.ebuild 987 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=(python{2_7,3_4})
  5. inherit vcs-snapshot distutils-r1
  6. DESCRIPTION="Stem is a Python controller library for Tor"
  7. HOMEPAGE="https://stem.torproject.org"
  8. SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
  9. LICENSE="LGPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
  12. IUSE="test"
  13. DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
  14. net-vpn/tor )
  15. dev-python/setuptools[${PYTHON_USEDEP}]"
  16. RDEPEND="net-vpn/tor"
  17. DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
  18. python_prepare_all() {
  19. # Disable failing test
  20. sed -i -e "/test_expand_path/a \
  21. \ \ \ \ return" test/integ/util/system.py || die
  22. sed -i -e "/test_get_connections_by_ss/,+1d"\
  23. test/integ/util/connection.py || die
  24. distutils-r1_python_prepare_all
  25. }
  26. python_test() {
  27. ${PYTHON} run_tests.py --all --target RUN_ALL || die
  28. }