txtorcon-0.13.0.ebuild 808 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=(python2_7)
  5. inherit distutils-r1
  6. DESCRIPTION="Twisted-based Tor controller client, with state-tracking and configuration abstractions"
  7. HOMEPAGE="https://github.com/meejah/txtorcon https://pypi.python.org/pypi/txtorcon"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="test"
  13. RDEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
  14. dev-python/ipaddr[${PYTHON_USEDEP}]
  15. net-vpn/tor
  16. dev-python/zope-interface[${PYTHON_USEDEP}]
  17. dev-python/geoip-python[${PYTHON_USEDEP}]"
  18. DEPEND="${RDEPEND}
  19. dev-python/setuptools[${PYTHON_USEDEP}]
  20. test? ( dev-python/mock[${PYTHON_USEDEP}] )"
  21. python_test() {
  22. trial --reporter=text test || die
  23. }