udns-0.4.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="Async-capable DNS stub resolver library"
  6. HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
  7. SRC_URI="http://www.corpit.ru/mjt/udns/${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd"
  11. IUSE="ipv6 static +tools"
  12. # Yes, this doesn't depend on any other library beside "system" set
  13. DEPEND=""
  14. RDEPEND=""
  15. src_configure() {
  16. # Uses non-standard configure script, econf doesn't work
  17. CC=$(tc-getCC) ./configure $(use_enable ipv6) || die "Configure failed"
  18. }
  19. src_compile() {
  20. if use tools; then
  21. emake shared
  22. else
  23. emake sharedlib
  24. fi
  25. }
  26. src_install() {
  27. dolib.so libudns.so.0
  28. dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so"
  29. if use tools; then
  30. newbin dnsget_s dnsget
  31. newbin ex-rdns_s ex-rdns
  32. newbin rblcheck_s rblcheck
  33. fi
  34. insinto /usr/include
  35. doins udns.h
  36. doman udns.3
  37. if use tools; then
  38. doman dnsget.1 rblcheck.1
  39. fi
  40. dodoc NEWS NOTES TODO
  41. }