mboxgrep-0.7.9-r1.ebuild 565 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Grep for mbox files"
  6. SRC_URI="mirror://sourceforge/mboxgrep/${P}.tar.gz"
  7. HOMEPAGE="http://mboxgrep.sf.net"
  8. DEPEND=""
  9. RDEPEND="${DEPEND}"
  10. SLOT="0"
  11. LICENSE="GPL-2+"
  12. KEYWORDS="~amd64 ppc x86"
  13. IUSE=""
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-ldflags.patch
  16. }
  17. src_install () {
  18. emake \
  19. prefix="${D}"/usr \
  20. mandir="${D}"/usr/share/man \
  21. infodir="${D}"/usr/share/info \
  22. install
  23. dodoc ChangeLog NEWS TODO README
  24. }