offlineimap-7.0.12.ebuild 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # Normally you need only one version of this.
  5. DISTUTILS_SINGLE_IMPL=1
  6. PYTHON_COMPAT=( python{2_7,3_4} )
  7. PYTHON_REQ_USE="threads,sqlite,ssl?"
  8. inherit distutils-r1
  9. DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
  10. HOMEPAGE="http://offlineimap.org"
  11. SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  15. IUSE="doc ssl"
  16. RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
  17. DEPEND="doc? ( app-text/asciidoc )"
  18. # see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
  19. PATCHES=(
  20. "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
  21. )
  22. src_compile() {
  23. distutils-r1_src_compile
  24. use doc && emake -C docs man
  25. }
  26. src_install() {
  27. distutils-r1_src_install
  28. dodoc offlineimap.conf offlineimap.conf.minimal
  29. use doc && doman docs/{offlineimap.1,offlineimapui.7}
  30. }
  31. pkg_postinst() {
  32. if [[ -z ${REPLACING_VERSIONS} ]]; then
  33. elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
  34. elog "Sample configurations are in /usr/share/doc/${PF}/"
  35. elog ""
  36. elog "If you connect via ssl/tls and don't use CA cert checking, it will"
  37. elog "display the server's cert fingerprint and require you to add it to the"
  38. elog "configuration file to be sure it connects to the same server every"
  39. elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
  40. elog "check SSL server certificate) in cases where you have no CA cert."
  41. fi
  42. }