blinkperl-20030301-r2.ebuild 703 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_P="${PN}-2003-02-08"
  5. S=${WORKDIR}/${PN}
  6. DESCRIPTION="blinkperl is a telnet server, which plays BlinkenLight movies"
  7. SRC_URI="mirror://sourceforge/blinkserv/${MY_P}.tar.gz"
  8. HOMEPAGE="http://blinkserv.sourceforge.net/"
  9. SLOT="0"
  10. KEYWORDS="~hppa x86"
  11. LICENSE="GPL-2"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="dev-lang/perl dev-perl/Term-ANSIScreen"
  15. PATCHES=( "${FILESDIR}"/${P}-fix-pod2man.patch
  16. "${FILESDIR}"/${P}-non-local.patch
  17. "${FILESDIR}"/${P}-Makefile.patch )
  18. src_install() {
  19. default
  20. newinitd "${FILESDIR}"/blinkperl.rc blinkperl
  21. newconfd "${FILESDIR}"/blinkperl.confd blinkperl
  22. }