csync-0.50.0.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="lightweight file synchronizer utility"
  6. HOMEPAGE="http://csync.org/"
  7. SRC_URI="https://open.cryptomilk.org/attachments/download/27/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc iconv samba +sftp test"
  12. RDEPEND=">=dev-db/sqlite-3.4:3
  13. net-libs/neon[ssl]
  14. iconv? ( virtual/libiconv )
  15. samba? ( >=net-fs/samba-3.5 )
  16. sftp? ( >=net-libs/libssh-0.5 )
  17. !net-misc/ocsync"
  18. DEPEND="${RDEPEND}
  19. app-text/asciidoc
  20. doc? ( app-doc/doxygen )
  21. test? ( dev-util/cmocka )"
  22. src_prepare() {
  23. cmake-utils_src_prepare
  24. sed -e "s/__FUNCTION__/__func__/" -i \
  25. src/csync_log.h tests/csync_tests/check_csync_log.c || die
  26. # proper docdir
  27. sed -e "s:/doc/${PN}:/doc/${PF}:" \
  28. -i doc/CMakeLists.txt || die
  29. }
  30. src_configure() {
  31. local mycmakeargs=(
  32. -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
  33. $(cmake-utils_use_with iconv ICONV)
  34. $(cmake-utils_use test UNIT_TESTING)
  35. $(cmake-utils_use_find_package doc Doxygen)
  36. $(cmake-utils_use_find_package samba Libsmbclient)
  37. $(cmake-utils_use_find_package sftp LibSSH)
  38. )
  39. cmake-utils_src_configure
  40. }