directvnc-0.7.8.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_IN_SOURCE_BUILD=1
  5. AUTOTOOLS_AUTORECONF=1
  6. inherit eutils autotools-utils
  7. DESCRIPTION="Very thin VNC client for unix framebuffer systems"
  8. HOMEPAGE="https://drinkmilk.github.com/directvnc/"
  9. SRC_URI="https://github.com/downloads/drinkmilk/${PN}/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~ppc ~x86"
  13. IUSE="+mouse dmalloc"
  14. RDEPEND="dev-libs/DirectFB[fbcon,dynload]
  15. virtual/jpeg"
  16. DEPEND="${RDEPEND}
  17. dmalloc? ( dev-libs/dmalloc )
  18. x11-proto/xproto"
  19. DOCS=( NEWS THANKS )
  20. src_prepare() {
  21. use mouse || epatch "${FILESDIR}"/${P}-mouse.patch
  22. # fix package version
  23. sed -i -e '/^AM_INIT_AUTOMAKE/s/0.7.7/0.7.8/g' configure.in || die
  24. # fix build system don't respect --docdir option
  25. sed -i -e 's|$(prefix)/share/doc/@PACKAGE@|@docdir@|g' Makefile.am || die
  26. autotools-utils_src_prepare
  27. }
  28. src_configure() {
  29. myeconfargs=(
  30. $(use_with dmalloc)
  31. )
  32. autotools-utils_src_configure
  33. }
  34. pkg_postinst() {
  35. einfo "To customize your keyboard mapping, please consult the manual"
  36. einfo " commmand: man 7 directvnc-kbmapping"
  37. }