fatrat-1.2.0_beta2.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Qt4-based download/upload manager"
  6. HOMEPAGE="http://fatrat.dolezel.info/"
  7. SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="bittorrent +curl doc xmpp nls webinterface"
  12. RDEPEND="dev-qt/qtdbus:4
  13. dev-qt/qtgui:4
  14. dev-qt/qtsvg:4
  15. bittorrent? ( >=net-libs/libtorrent-rasterbar-0.14.5
  16. >=dev-cpp/asio-1.1.0
  17. dev-qt/qtwebkit:4 )
  18. curl? ( >=net-misc/curl-7.18.2 )
  19. doc? ( dev-qt/qthelp:4 )
  20. xmpp? ( net-libs/gloox )
  21. webinterface? ( dev-qt/qtscript:4 )"
  22. DEPEND="${RDEPEND}
  23. nls? ( sys-devel/gettext )"
  24. PATCHES=(
  25. "${FILESDIR}/${P}-build.patch"
  26. "${FILESDIR}/${P}-libcrypto_linking.patch"
  27. )
  28. src_configure() {
  29. local mycmakeargs="
  30. $(cmake-utils_use_with bittorrent) \
  31. $(cmake-utils_use_with curl) \
  32. $(cmake-utils_use_with doc DOCUMENTATION) \
  33. $(cmake-utils_use_with xmpp JABBER) \
  34. $(cmake-utils_use_with nls) \
  35. $(cmake-utils_use_with webinterface)"
  36. cmake-utils_src_configure
  37. }
  38. src_install() {
  39. use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
  40. cmake-utils_src_install
  41. }
  42. pkg_postinst() {
  43. # this is a completely optional and NOT automagic dep
  44. if ! has_version dev-libs/geoip; then
  45. elog "If you want the GeoIP support, then emerge dev-libs/geoip."
  46. fi
  47. }