gsutil-3.42.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="command line tool for interacting with cloud storage services"
  7. HOMEPAGE="https://github.com/GoogleCloudPlatform/gsutil"
  8. SRC_URI="http://commondatastorage.googleapis.com/pub/${PN}_${PV}.tar.gz"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~x86"
  12. IUSE=""
  13. DEPEND="${PYTHON_DEPS}"
  14. RDEPEND="${DEPEND}
  15. >=dev-python/boto-2.22.1[${PYTHON_USEDEP}]
  16. >=dev-python/crcmod-1.7
  17. >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
  18. >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
  19. >=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
  20. >=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]
  21. >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
  22. dev-python/setuptools[${PYTHON_USEDEP}]
  23. >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
  24. "
  25. S=${WORKDIR}/${PN}
  26. DOCS=( README.md CHANGES.md )
  27. PATCHES=(
  28. "${FILESDIR}/${P}-use-friendy-version-checks.patch"
  29. "${FILESDIR}/${PN}-3.37-drop-http_proxy-clearing.patch"
  30. )
  31. python_prepare_all() {
  32. distutils-r1_python_prepare_all
  33. sed \
  34. -e '/SocksiPy-branch/d' \
  35. -i setup.py || die
  36. }
  37. python_test() {
  38. export BOTO_CONFIG=${FILESDIR}/dummy.boto
  39. ${PYTHON} gslib/__main__.py test -u || die "tests failed"
  40. }