hotot-0.9.8.14_p20130514-r1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit cmake-utils python-single-r1 vcs-snapshot
  6. DESCRIPTION="lightweight & open source microblogging client"
  7. HOMEPAGE="http://hotot.org"
  8. SRC_URI="https://github.com/lyricat/Hotot/tarball/ed2ff013 -> ${P}.tar.gz"
  9. LICENSE="LGPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="chrome kde qt4"
  13. REQUIRED_USE="|| ( chrome qt4 ) ${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. dev-python/dbus-python[${PYTHON_USEDEP}]
  16. qt4? ( dev-qt/qtwebkit:4
  17. kde? ( kde-frameworks/kdelibs:4 ) )
  18. "
  19. DEPEND="${RDEPEND}
  20. sys-devel/gettext
  21. qt4? ( dev-qt/qtsql:4 )
  22. "
  23. pkg_setup() {
  24. python-single-r1_pkg_setup
  25. }
  26. src_configure() {
  27. mycmakeargs=(
  28. ${mycmakeargs}
  29. $(cmake-utils_use_with chrome CHROME)
  30. -DWITH_GTK=OFF
  31. -DWITH_GTK2=OFF
  32. -DWITH_GTK3=OFF
  33. $(cmake-utils_use_with kde KDE)
  34. $(cmake-utils_use_with qt4 QT)
  35. -DPYTHON_EXECUTABLE=${PYTHON} )
  36. cmake-utils_src_configure
  37. }
  38. src_install() {
  39. cmake-utils_src_install
  40. find "${D}" -name "*.pyc" -print -delete
  41. }
  42. pkg_postinst() {
  43. if use chrome; then
  44. elog "TO install hotot for chrome, open chromium/google-chrome,"
  45. elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
  46. elog "as unpacked extension."
  47. fi
  48. }