hsc-1.0b.ebuild 873 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit autotools eutils
  4. DESCRIPTION="An HTML preprocessor using ML syntax"
  5. HOMEPAGE="http://www.linguistik.uni-erlangen.de/~msbethke/software.html"
  6. SRC_URI="http://www.linguistik.uni-erlangen.de/~msbethke/binaries/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~ppc x86"
  10. IUSE=""
  11. S=${WORKDIR}/${PN}-${PV/b/}
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}/${P}-cflags.patch"
  16. epatch "${FILESDIR}/${P}-nostrip.patch"
  17. epatch "${FILESDIR}/${P}-parmake.patch"
  18. epatch "${FILESDIR}"/${P}-glibc-2.10.patch
  19. eautoreconf
  20. }
  21. src_install() {
  22. dodir /usr/share/hsc
  23. emake BINDIR="${D}/usr/bin" DATADIR="${D}/usr/share/hsc" \
  24. prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" \
  25. datadir="${D}/usr/share/hsc" install || die "make install failed"
  26. }