ifenslave-1.1.0-r6.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MY_PN="ifenslave-2.6" # this is NOT an error
  5. DEBIAN_PV="17"
  6. DEBIANPKG_TARBALL="${MY_PN}_${PV}.orig.tar.gz"
  7. DEBIANPKG_PATCH="${MY_PN}_${PV}-${DEBIAN_PV}.debian.tar.gz"
  8. DEBIANPKG_BASE="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}"
  9. inherit toolchain-funcs linux-info
  10. DESCRIPTION="Attach and detach slave interfaces to a bonding device"
  11. HOMEPAGE="http://sf.net/projects/bonding/"
  12. SRC_URI="${DEBIANPKG_BASE}/${DEBIANPKG_TARBALL}
  13. ${DEBIANPKG_BASE}/${DEBIANPKG_PATCH}"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. KEYWORDS="~alpha amd64 ~arm ~mips ppc sparc x86"
  17. IUSE=""
  18. RDEPEND=""
  19. DEPEND="sys-devel/gcc
  20. >=sys-kernel/linux-headers-2.4.22
  21. ${RDEPEND}"
  22. CONFIG_CHECK="~BONDING"
  23. WARNING_BONDING="CONFIG_BONDING is required to get bond devices in the kernel"
  24. src_compile() {
  25. $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -o ${PN} || die "Failed to compile!"
  26. }
  27. src_install() {
  28. into /
  29. dosbin ${PN}
  30. into
  31. # there really is no better documentation than the sourcecode :-)
  32. dodoc ${PN}.c
  33. doman "${WORKDIR}/debian/${PN}.8"
  34. }
  35. pkg_preinst() {
  36. if [[ -f /etc/modules.d/bond ]] || [[ -f /etc/modprobe.d/bond ]]; then
  37. elog "You may want to remove /etc/modules.d/bond and/or /etc/modprobe.d/bond"
  38. elog "because it likely causes some deprecation warnings like:"
  39. elog "Loading kernel module for a network device with CAP_SYS_MODULE (deprecated). Use CAP_NET_ADMIN and alias netdev-bond0 instead"
  40. elog "It may also cause unexpected behaviour."
  41. fi
  42. }