netsed-0.01b.ebuild 654 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="Small tool for altering forwarded network data in real time"
  5. HOMEPAGE="http://freshmeat.net/projects/netsed"
  6. SRC_URI="http://dione.ids.pl/~lcamtuf/${PN}.tgz
  7. http://http.us.debian.org/debian/pool/main/n/netsed/${PN}_0.01c-2.diff.gz"
  8. LICENSE="LGPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. src_unpack() {
  14. mkdir -p "${S}"
  15. cd "${S}"
  16. unpack ${A}
  17. }
  18. src_compile() {
  19. epatch "${DISTDIR}"/${PN}_0.01c-2.diff.gz
  20. make CFLAGS="${CFLAGS}"
  21. }
  22. src_install() {
  23. dobin netsed
  24. doman debian/netsed.1
  25. dodoc README
  26. }