rdate-1.4-r3.ebuild 748 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit flag-o-matic toolchain-funcs
  4. DESCRIPTION="use TCP or UDP to retrieve the current time of another machine"
  5. HOMEPAGE="http://www.apps.ietf.org/rfc/rfc868.html"
  6. SRC_URI="ftp://people.redhat.com/sopwith/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
  10. IUSE="ipv6"
  11. DEPEND=""
  12. src_compile() {
  13. use ipv6 && append-cppflags "-DINET6"
  14. emake RCFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
  15. }
  16. src_install(){
  17. emake -j1 prefix="${D}/usr" install || die "make install failed"
  18. newinitd "${FILESDIR}"/rdate-initd-1.4-r3 rdate
  19. newconfd "${FILESDIR}"/rdate-confd rdate
  20. }