ris-linux-0.4-r1.ebuild 790 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="BINL server to doing Windows(r) RIS"
  8. HOMEPAGE="http://oss.netfarm.it/guides/pxe.php"
  9. SRC_URI="http://oss.netfarm.it/guides/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND=""
  15. RDEPEND="${DEPEND}
  16. || ( net-ftp/atftp net-ftp/tftp-hpa )
  17. net-misc/dhcp
  18. net-fs/samba
  19. sys-boot/syslinux"
  20. python_prepare_all(){
  21. sed "s:VERSION:${PV}:" "${FILESDIR}"/setup.py > "${S}"/setup.py
  22. distutils-r1_python_prepare_all
  23. }
  24. python_install_all() {
  25. distutils-r1_python_install_all
  26. newinitd "${FILESDIR}"/binlsrv.initd binlsrv
  27. newconfd "${FILESDIR}"/binlsrv.confd binlsrv
  28. }