spread-4.3.0-r1.ebuild 712 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit user
  5. MY_PN="spread-src"
  6. DESCRIPTION="Distributed network messaging system"
  7. HOMEPAGE="http://www.spread.org"
  8. SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
  9. LICENSE="Spread-1.0 GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~x86 ~amd64"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND="${DEPEND}"
  15. S="${WORKDIR}/${MY_PN}-${PV}"
  16. pkg_setup() {
  17. enewuser spread
  18. enewgroup spread
  19. }
  20. src_prepare() {
  21. default
  22. # don't strip binaries
  23. sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
  27. newinitd "${FILESDIR}"/spread.init.d spread
  28. }