taptap-1.0.ebuild 638 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit toolchain-funcs
  5. DESCRIPTION="A program to link two /dev/net/tun to form virtual ethernet"
  6. HOMEPAGE="http://www.munted.org.uk/programming/taptap/"
  7. SRC_URI="http://www.munted.org.uk/programming/${PN}/${P}.tar.bz2"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~sparc ~x86"
  11. IUSE=""
  12. S=${WORKDIR}/${PN}
  13. src_prepare() {
  14. sed -i \
  15. -e 's:= -Wall -s:+= -Wall:' \
  16. -e 's:$(CFLAGS):$(LDFLAGS) &:' \
  17. Makefile || die
  18. }
  19. src_compile() {
  20. emake CC="$(tc-getCC)" || die
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" install || die
  24. }