udpxy-1.0.23.7-r2.ebuild 789 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils systemd toolchain-funcs versionator
  5. MY_PV=$(replace_version_separator 3 -)
  6. DESCRIPTION="Small-footprint daemon to relay multicast UDP traffic to client's TCP (HTTP) connection"
  7. HOMEPAGE="https://sourceforge.net/projects/udpxy/"
  8. SRC_URI="http://www.udpxy.com/download/1_23/${PN}.${MY_PV}-prod.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. S="${WORKDIR}/${PN}-${MY_PV}"
  13. src_prepare() {
  14. eapply_user
  15. tc-export CC
  16. }
  17. src_install() {
  18. dobin udpxy
  19. dosym udpxy /usr/bin/udpxrec
  20. doman doc/en/*.1
  21. dodoc CHANGES README
  22. newinitd "${FILESDIR}/${PN}.initd" ${PN}
  23. newconfd "${FILESDIR}/${PN}.confd" ${PN}
  24. systemd_dounit "${FILESDIR}/${PN}.service"
  25. }