wput-0.6.1.ebuild 972 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="A tiny, wget-alike program, that is designed to upload files/whole directories to remote ftp-servers"
  5. HOMEPAGE="http://wput.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc ~sparc x86"
  10. IUSE="debug nls ssl"
  11. RDEPEND="ssl? ( net-libs/gnutls )"
  12. DEPEND="${RDEPEND}
  13. nls? ( sys-devel/gettext )"
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${FILESDIR}/${PN}-0.6-gentoo.diff"
  18. # Fix bug 126828
  19. epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
  20. }
  21. src_compile() {
  22. local myconf
  23. use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
  24. econf ${myconf} \
  25. $(use_enable nls) \
  26. $(use_with ssl) || die "econf failed"
  27. emake || die "emake failed"
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install || die "make install failed"
  31. dodoc ChangeLog INSTALL TODO
  32. }