smbldap-tools-0.9.10-r1.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="Samba LDAP management tools"
  6. HOMEPAGE="https://gna.org/projects/smbldap-tools/"
  7. SRC_URI="http://download.gna.org/smbldap-tools/sources/${PV}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. dev-perl/perl-ldap
  14. dev-perl/Crypt-SmbHash
  15. dev-perl/Digest-SHA1
  16. dev-perl/Unicode-MapUTF8
  17. dev-perl/IO-Socket-SSL
  18. net-nds/openldap
  19. net-fs/samba
  20. "
  21. DEPEND="${RDEPEND}"
  22. src_prepare() {
  23. epatch "${FILESDIR}"/${P}-smbldap-config-pod.patch
  24. }
  25. src_install() {
  26. default
  27. newsbin smbldap-config.cmd smbldap-config
  28. dosym smbldap-passwd /usr/sbin/smbldap-passwd.cmd
  29. dodoc CONTRIBUTORS ChangeLog FILES INFRA INSTALL README TODO doc/*conf* doc/smbldap-tools*
  30. dodoc -r doc/migration_scripts
  31. sed -i 's/.CMD//g' smbldap-[gpu]*.8 || die
  32. doman smbldap-[gpu]*.8
  33. insinto /etc/smbldap-tools
  34. doins smbldap.conf smbldap_bind.conf
  35. elog "Remember to read INSTALL when updating."
  36. }
  37. pkg_postinst() {
  38. elog "- A good howto is found on http://download.gna.org/smbldap-tools/docs/samba-ldap-howto/"
  39. elog " and http://download.gna.org/smbldap-tools/docs/smbldap-tools/"
  40. elog "- The configure script is installed as smbldap-configure.pl. Please run it to configure the tools."
  41. elog "- Examples configuration files for Samba and slapd have been copied to ${EPREFIX}/usr/share/doc/${PF},"
  42. elog " together with the migration-scripts."
  43. elog "- Also remember to read INSTALL when updating."
  44. }