rsstool-1.0.1_rc2.ebuild 733 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. MY_P=${PN}-${PV/_}
  6. DESCRIPTION="cmdline tool to read, parse, merge, and write RSS (and Atom) feeds"
  7. HOMEPAGE="http://rsstool.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-libs/libxml2
  14. net-misc/curl"
  15. DEPEND="${RDEPEND}
  16. app-arch/unzip"
  17. S=${WORKDIR}/${MY_P}-src/src
  18. src_prepare() {
  19. sed -e '1i#!/bin/bash' -i configure || die
  20. }
  21. src_compile() {
  22. emake CC="$(tc-getCC)"
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" BINDIR="/usr/bin" install
  26. dohtml ../{changes,faq,readme}.html
  27. }