cups-pk-helper-0.2.5.ebuild 1003 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. inherit gnome2
  6. DESCRIPTION="PolicyKit helper to configure cups with fine-grained privileges"
  7. HOMEPAGE="https://www.freedesktop.org/wiki/Software/cups-pk-helper"
  8. SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
  9. LICENSE="GPL-2+"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
  12. IUSE=""
  13. # Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
  14. # and 2.30.0
  15. COMMON_DEPEND="
  16. >=dev-libs/glib-2.30.0:2
  17. net-print/cups
  18. >=sys-auth/polkit-0.97
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. sys-apps/dbus
  22. "
  23. DEPEND="${COMMON_DEPEND}
  24. >=dev-util/gdbus-codegen-2.30.0
  25. >=dev-util/intltool-0.40.6
  26. virtual/pkgconfig
  27. sys-devel/gettext
  28. "
  29. src_prepare() {
  30. DOCS="AUTHORS HACKING NEWS README"
  31. # Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
  32. rm -v src/cph-iface-mechanism.{c,h} || die
  33. gnome2_src_prepare
  34. }