epson-inkjet-printer-escpr-1.6.10.ebuild 874 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)"
  5. HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
  6. SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/05/20/91/05b7c89713fa620593175010796eecfbfe73cb9a/epson-inkjet-printer-escpr-1.6.10-1lsb3.2.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPEND="net-print/cups"
  12. RDEPEND="${DEPEND}"
  13. PATCHES=(
  14. "${FILESDIR}/1.6.5-warnings.patch"
  15. )
  16. src_configure() {
  17. econf --disable-shared
  18. # Makefile calls ls to generate a file list which is included in Makefile.am
  19. # Set the collation to C to avoid automake being called automatically
  20. unset LC_ALL
  21. export LC_COLLATE=C
  22. }
  23. src_install() {
  24. emake -C ppd DESTDIR="${D}" install
  25. emake -C src DESTDIR="${D}" install
  26. einstalldocs
  27. }