libgnomecups-0.2.3-r5.ebuild 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG="yes"
  5. GNOME_TARBALL_SUFFIX="bz2"
  6. inherit autotools eutils gnome2 multilib-minimal
  7. DESCRIPTION="GNOME cups library"
  8. HOMEPAGE="https://www.gnome.org/"
  9. LICENSE="GPL-2 LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="
  14. >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
  15. >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}]
  16. "
  17. DEPEND="${RDEPEND}
  18. >=dev-util/intltool-0.28
  19. gnome-base/gnome-common
  20. >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
  21. "
  22. src_prepare() {
  23. epatch "${FILESDIR}"/enablenet.patch
  24. # Fix .pc file per bug #235013
  25. epatch "${FILESDIR}"/${P}-pkgconfig.patch
  26. # Upstream fix for g_list_find_custom() argument order
  27. epatch "${FILESDIR}/${P}-g_list_find_custom.patch"
  28. # >=glib-2.31 compat, bug #400789, https://bugzilla.gnome.org/show_bug.cgi?id=664930
  29. epatch "${FILESDIR}/${P}-glib.h.patch"
  30. # cups-1.6 compat, bug #428812
  31. epatch "${FILESDIR}/${P}-cups-1.6.patch"
  32. # so it looks for cups-config... how about using $CUPS_CONFIG then?
  33. # and also use AC_PATH_TOOL to respect $CHOST
  34. epatch "${FILESDIR}/${P}-cups-config.patch"
  35. # Fix building with -Werror=format-security, bug #517612
  36. epatch "${FILESDIR}/${P}-format-string.patch"
  37. # Look for lpoptions in the right spot, upstream bug #520449
  38. epatch "${FILESDIR}/${P}-lpoptions.patch"
  39. eautoreconf # To fix intltool files making LINGUAS to be honored
  40. gnome2_src_prepare
  41. }
  42. multilib_src_configure() {
  43. ECONF_SOURCE=${S} \
  44. gnome2_src_configure --disable-static
  45. }
  46. multilib_src_install() {
  47. gnome2_src_install
  48. }