npadmin-0.8.7-r1.ebuild 578 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Network printer command-line adminstration tool"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. HOMEPAGE="http://npadmin.sourceforge.net/"
  8. # this does NOT link against SNMP
  9. DEPEND=""
  10. KEYWORDS="~x86 ~amd64 ~ppc"
  11. IUSE=""
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. PATCHES=(
  15. "${FILESDIR}"/${P}-stdlib.patch
  16. "${FILESDIR}"/${P}-gcc6.patch
  17. )
  18. src_install() {
  19. dobin npadmin
  20. doman npadmin.1
  21. dodoc README AUTHORS ChangeLog INSTALL NEWS README TODO
  22. }