aiccu-2007.01.15-r5.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils linux-info systemd toolchain-funcs
  5. DESCRIPTION="AICCU Client to configure an IPv6 tunnel to SixXS"
  6. HOMEPAGE="http://www.sixxs.net/tools/aiccu"
  7. SRC_URI="http://www.sixxs.net/archive/sixxs/aiccu/unix/${PN}_${PV//\./}.tar.gz"
  8. LICENSE="SixXS"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm hppa ppc sparc x86"
  11. IUSE="systemd"
  12. RDEPEND="
  13. net-libs/gnutls
  14. sys-apps/iproute2
  15. systemd? ( sys-apps/systemd )
  16. "
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. "
  20. S=${WORKDIR}/${PN}
  21. CONFIG_CHECK="~TUN"
  22. src_prepare() {
  23. epatch \
  24. "${FILESDIR}"/${P}-r2-init.gentoo.patch \
  25. "${FILESDIR}"/${P}-Makefile.patch \
  26. "${FILESDIR}"/${P}-setupscript.patch \
  27. "${FILESDIR}"/${P}-uclibc.patch \
  28. "${FILESDIR}"/${P}-systemd.patch \
  29. "${FILESDIR}"/${P}-gnutls-3.4.patch
  30. }
  31. src_compile() {
  32. # Don't use main Makefile since it requires additional
  33. # dependencies which are useless for us.
  34. emake CC=$(tc-getCC) STRIP= -C unix-console \
  35. HAVE_SYSTEMD=$(usex systemd 1 0)
  36. }
  37. src_install() {
  38. dosbin unix-console/${PN}
  39. insopts -m 600
  40. insinto /etc
  41. doins doc/${PN}.conf
  42. newinitd doc/${PN}.init.gentoo ${PN}
  43. use systemd && systemd_dounit doc/${PN}.service
  44. dodoc doc/{HOWTO,README,changelog}
  45. }