gr-iqbal-9999.ebuild 707 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit cmake-utils python-single-r1
  6. DESCRIPTION="gnuradio I/Q balancing"
  7. HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
  8. if [[ ${PV} == 9999* ]]; then
  9. inherit git-r3
  10. SRC_URI=""
  11. EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
  12. KEYWORDS=""
  13. else
  14. SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
  15. KEYWORDS="~amd64 ~arm ~x86"
  16. fi
  17. LICENSE="GPL-3"
  18. SLOT="0/${PV}"
  19. IUSE=""
  20. RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
  21. net-libs/libosmo-dsp:=
  22. dev-libs/boost:=
  23. ${PYTHON_DEPS}"
  24. DEPEND="${RDEPEND}"
  25. REQUIRED_USE="${PYTHON_REQUIRED_USE}"