12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- inherit toolchain-funcs
- DESCRIPTION="nl80211-based configuration utility for wireless devices using the mac80211 kernel stack"
- HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/iw"
- SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
- LICENSE="ISC"
- SLOT="0"
- KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
- IUSE=""
- RDEPEND="dev-libs/libnl"
- DEPEND="${RDEPEND}
- virtual/pkgconfig"
- src_prepare() {
- tc-export CC LD PKG_CONFIG
- }
- src_compile() {
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${CFLAGS} ${LDFLAGS}" \
- emake V=1
- }
- src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
- }
|