madwimax-0.1.1-r1.ebuild 934 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools linux-info udev
  5. DESCRIPTION="A reverse-engineered Linux driver for mobile WiMAX devices based on Samsung CMC-730 chip"
  6. HOMEPAGE="https://code.google.com/p/madwimax/"
  7. SRC_URI="https://madwimax.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. IUSE="doc"
  12. RDEPEND="virtual/libusb:1"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. doc? (
  16. app-text/asciidoc
  17. app-text/docbook2X
  18. )"
  19. CONFIG_CHECK="~TUN"
  20. src_prepare() {
  21. sed -i -e "s:\(for name in docbook2\)x-man:\1man\.pl:" configure.ac || die
  22. eautoreconf
  23. }
  24. src_configure() {
  25. local myconf
  26. use doc || myconf="--without-man-pages"
  27. econf ${myconf}
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" udevrulesdir="$(get_udevdir)"/rules.d install
  31. mv "${ED}/$(get_udevdir)"/rules.d/{z60_,60-}madwimax.rules || die
  32. dodoc README
  33. }