aria-2.3.2_p20130826.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="tk"
  6. inherit eutils python-single-r1 versionator
  7. MY_P="${PN}$(get_version_component_range 1-2 ${PV})"
  8. DATE="08.26.2013"
  9. DESCRIPTION="Automated NOE assignment and NMR structure calculation"
  10. HOMEPAGE="http://aria.pasteur.fr/"
  11. SRC_URI="http://aria.pasteur.fr/archives/${MY_P}.2_${DATE}.tar.gz"
  12. SLOT="0"
  13. LICENSE="cns"
  14. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  15. IUSE="examples"
  16. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  17. RDEPEND="
  18. ${PYTHON_DEPS}
  19. dev-tcltk/tix
  20. dev-lang/tk:0=
  21. >=dev-python/numpy-1.1[${PYTHON_USEDEP}]
  22. dev-python/matplotlib[${PYTHON_USEDEP},tk]
  23. >=sci-chemistry/cns-1.2.1-r7[aria,openmp]
  24. >=sci-chemistry/ccpn-2.2[${PYTHON_USEDEP}]
  25. sci-chemistry/clashlist
  26. sci-chemistry/procheck
  27. sci-libs/clashscore-db"
  28. DEPEND="${RDEPEND}"
  29. RESTRICT="fetch"
  30. S="${WORKDIR}/${MY_P}"
  31. pkg_nofetch(){
  32. einfo "Go to http://aria.pasteur.fr/archives/aria2.3.2.tar.gz/view, download ${A}"
  33. einfo "and place it in ${DISTDIR}"
  34. }
  35. pkg_setup() {
  36. python-single-r1_pkg_setup
  37. }
  38. src_test(){
  39. export CCPNMR_TOP_DIR=$(python_get_sitedir)
  40. export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
  41. ${PYTHON} check.py || die
  42. }
  43. src_install(){
  44. python_moduleinto ${PN}
  45. python_domodule src aria2.py
  46. python_moduleinto ${PN}/cns
  47. python_domodule cns/{protocols,toppar,src/helplib}
  48. if use examples; then
  49. insinto /usr/share/${P}/
  50. doins -r examples
  51. fi
  52. # ENV
  53. cat >> "${T}"/20aria <<- EOF
  54. ARIA2="$(python_get_sitedir)/${PN}"
  55. EOF
  56. doenvd "${T}"/20aria
  57. # Launch Wrapper
  58. cat >> "${T}"/aria <<- EOF
  59. #!/bin/sh
  60. export CCPNMR_TOP_DIR="$(python_get_sitedir)"
  61. export PYTHONPATH="$(python_get_sitedir)/ccpn/python"
  62. exec "${PYTHON}" -O "\${ARIA2}"/aria2.py \$@
  63. EOF
  64. dobin "${T}"/aria
  65. dosym aria /usr/bin/aria2
  66. dodoc README
  67. python_optimize "${D}/$(python_get_sitedir)"
  68. }