chemtool-1.6.14.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils eutils
  6. DESCRIPTION="A GTK program for drawing organic molecules"
  7. HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
  8. SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE="emf gnome nls"
  13. RDEPEND="
  14. dev-libs/glib:2
  15. media-gfx/transfig
  16. x11-libs/gtk+:2
  17. x11-libs/libX11
  18. x11-libs/pango
  19. emf? ( media-libs/libemf )"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig"
  22. AUTOTOOLS_IN_SOURCE_BUILD=1
  23. PATCHES=(
  24. "${FILESDIR}"/1.6.13-no-underlinking.patch
  25. )
  26. src_configure() {
  27. local myeconfargs=(
  28. --without-kdedir
  29. $(use_with gnome gnomedir /usr)
  30. $(use_enable emf)
  31. --enable-undo
  32. --enable-menu
  33. )
  34. autotools-utils_src_configure
  35. }
  36. src_install() {
  37. autotools-utils_src_install
  38. insinto /usr/share/${PN}/examples
  39. doins "${S}"/examples/*
  40. if ! use nls; then rm -rf "${ED}"/usr/share/locale || die; fi
  41. insinto /usr/share/pixmaps
  42. doins chemtool.xpm
  43. make_desktop_entry ${PN} Chemtool ${PN} "Education;Science;Chemistry"
  44. }