dssp-2.2.1-r1.ebuild 901 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="The protein secondary structure standard"
  6. HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
  7. SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/${P}.tgz"
  8. LICENSE="Boost-1.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="dev-libs/boost:=[threads]"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. tc-export CXX
  16. cat >> make.config <<- EOF
  17. BOOST_LIB_SUFFIX = -mt
  18. BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
  19. BOOST_INC_DIR = "${EPREFIX}/usr/include"
  20. EOF
  21. epatch \
  22. "${FILESDIR}"/${PN}-2.1.0-gentoo.patch
  23. }
  24. src_install() {
  25. dobin mkdssp
  26. dosym mkdssp /usr/bin/dssp
  27. doman doc/mkdssp.1
  28. dodoc README.txt changelog
  29. cat >> "${T}"/30-${PN} <<- EOF
  30. DSSP="${EPREFIX}"/usr/bin/${PN}
  31. EOF
  32. doenvd "${T}"/30-${PN}
  33. }