freeon-1.0.10.ebuild 645 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. FORTRAN_STANDARD=90
  5. PYTHON_COMPAT=( python{2_7,3_4} )
  6. inherit autotools fortran-2 python-any-r1
  7. DESCRIPTION="An experimental suite of programs for linear scaling quantum chemistry"
  8. HOMEPAGE="http://www.freeon.org"
  9. SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND="
  15. sci-libs/hdf5
  16. virtual/blas
  17. virtual/lapack"
  18. DEPEND="${RDEPEND}
  19. ${PYTHON_DEPS}"
  20. PATCHES=(
  21. "${FILESDIR}"/${P}-stop.patch
  22. )
  23. src_prepare() {
  24. default
  25. eautoreconf
  26. }