gperiodic-2.0.10-r2.ebuild 983 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Periodic table application for Linux"
  6. HOMEPAGE="http://www.frantz.fi/software/gperiodic.php"
  7. SRC_URI="http://www.frantz.fi/software/${P}.tar.gz"
  8. KEYWORDS="amd64 x86"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. IUSE="nls"
  12. RDEPEND="
  13. sys-libs/ncurses:0
  14. x11-libs/gtk+:2
  15. x11-libs/cairo[X]
  16. nls? ( sys-devel/gettext )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. src_prepare() {
  20. epatch \
  21. "${FILESDIR}"/${P}-makefile.patch \
  22. "${FILESDIR}"/${P}-nls.patch
  23. sed \
  24. -e '/Encoding/d' \
  25. -i ${PN}.desktop || die
  26. }
  27. src_compile() {
  28. local myopts
  29. use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
  30. emake CC=$(tc-getCC) ${myopts}
  31. }
  32. src_install() {
  33. local myopts
  34. use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
  35. emake DESTDIR="${D}" ${myopts} install
  36. dodoc AUTHORS ChangeLog README NEWS
  37. newdoc po/README README.translation
  38. }