hollow-1.2-r1.ebuild 832 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-r1
  6. DESCRIPTION="Production of surface images of proteins"
  7. HOMEPAGE="http://hollow.sourceforge.net/"
  8. #SRC_URI="mirror://sourceforge/${P}.zip"
  9. SRC_URI="http://hollow.sourceforge.net/${P}.zip"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. LICENSE="GPL-3"
  13. IUSE=""
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. RDEPEND="${PYTHON_DEPS}
  16. sci-chemistry/pymol[${PYTHON_USEDEP}]"
  17. DEPEND="${PYTHON_DEPS}
  18. app-arch/unzip"
  19. src_install() {
  20. python_setup
  21. esvn_clean
  22. python_foreach_impl python_domodule pdbstruct
  23. python_moduleinto ${PN}
  24. python_foreach_impl python_domodule *.py hollow.txt
  25. python_foreach_impl python_newscript ${PN}.py ${PN}
  26. dodoc README
  27. python_optimize
  28. }