propka-3.1_p140511.ebuild 818 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Prediction of the pKa values of ionizable groups in proteins and protein-ligand complexes"
  7. HOMEPAGE="http://propka.ki.ku.dk/"
  8. SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
  9. SLOT="0"
  10. LICENSE="all-rights-reserved"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE=""
  13. DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  14. RESTRICT="mirror bindist"
  15. python_prepare_all() {
  16. sed -e "/exclude/s:scripts:\', \'Tests:g" \
  17. -i setup.py || die
  18. distutils-r1_python_prepare_all
  19. }
  20. python_test() {
  21. cd Tests || die
  22. ${PYTHON} runtest.py || die
  23. }
  24. python_install_all() {
  25. dosym ${PN}31 /usr/bin/${PN}
  26. distutils-r1_python_install_all
  27. }