pymol-plugins-emovie-1.0.4.ebuild 769 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-r1
  6. DESCRIPTION="PyMOL plugin for convinient movie creation"
  7. SRC_URI="http://www.weizmann.ac.il/ISPC/eMovie_package.zip"
  8. HOMEPAGE="http://www.weizmann.ac.il/ISPC/eMovie.html"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. KEYWORDS="~x86 ~amd64 ~x86-linux ~amd64-linux"
  12. IUSE=""
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. >sci-chemistry/pymol-0.99[${PYTHON_USEDEP}]"
  16. DEPEND="app-arch/unzip"
  17. S="${WORKDIR}"
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${PV}-indent.patch
  20. }
  21. src_install(){
  22. python_moduleinto pmg_tk/startup
  23. python_foreach_impl python_domodule eMovie.py
  24. python_foreach_impl python_optimize
  25. }