relax-4.0.0-r1.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. WX_GTK_VER="3.0"
  6. inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
  7. DESCRIPTION="Molecular dynamics by NMR data analysis"
  8. HOMEPAGE="http://www.nmr-relax.com/"
  9. SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  13. IUSE="test"
  14. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  15. RDEPEND="
  16. ${PYTHON_DEPS}
  17. dev-python/Numdifftools[${PYTHON_USEDEP}]
  18. dev-python/matplotlib[${PYTHON_USEDEP}]
  19. dev-python/numpy[${PYTHON_USEDEP}]
  20. dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
  21. sci-chemistry/molmol
  22. sci-chemistry/pymol[${PYTHON_USEDEP}]
  23. sci-chemistry/vmd
  24. >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
  25. >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
  26. sci-libs/scipy[${PYTHON_USEDEP}]
  27. sci-visualization/grace
  28. sci-visualization/opendx
  29. x11-libs/wxGTK:${WX_GTK_VER}[X]"
  30. DEPEND="${RDEPEND}
  31. media-gfx/pngcrush
  32. test? ( ${RDEPEND} )
  33. "
  34. pkg_setup() {
  35. python-single-r1_pkg_setup
  36. }
  37. src_prepare() {
  38. rm -rf minfx bmrblib extern/numdifftools || die
  39. tc-export CC
  40. need-wxwidgets unicode
  41. }
  42. src_compile() {
  43. escons
  44. }
  45. src_test() {
  46. VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
  47. virtualmake
  48. }
  49. src_install() {
  50. dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
  51. python_moduleinto ${PN}
  52. python_domodule *
  53. rm ${PN} README || die
  54. make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
  55. }