threeV-1.2.ebuild 686 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="3V: Voss Volume Voxelator"
  6. HOMEPAGE="http://geometry.molmovdb.org/3v/"
  7. SRC_URI="http://geometry.molmovdb.org/3v/3v-${PV}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. PDEPEND="sci-chemistry/msms-bin"
  13. # sci-chemistry/usf-rave"
  14. S="${WORKDIR}/3v-${PV}/src"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PV}-gentoo.patch
  17. tc-export CXX
  18. emake distclean || die
  19. }
  20. src_install() {
  21. emake DESTDIR="${ED}" install || die
  22. cd ..
  23. dodoc AUTHORS ChangeLog QUICKSTART README TODO VERSION || die
  24. }