gerbv-2.6.0.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit fdo-mime
  5. DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. HOMEPAGE="http://gerbv.geda-project.org/"
  8. IUSE="doc examples static-libs unit-mm"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. KEYWORDS="amd64 ppc x86"
  12. RESTRICT="test"
  13. RDEPEND="
  14. x11-libs/gtk+:2
  15. x11-libs/cairo"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_configure() {
  19. econf \
  20. $(use_enable unit-mm) \
  21. --disable-update-desktop-database \
  22. $(use_enable static-libs static)
  23. }
  24. src_install () {
  25. emake DESTDIR="${D}" install
  26. dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
  27. rm doc/Doxyfile.nopreprocessing
  28. if use doc; then
  29. find doc -name "Makefile*" -exec rm -f '{}' \;
  30. dodoc -r doc/*
  31. fi
  32. if use examples; then
  33. find example -name "Makefile*" -exec rm -f '{}' \;
  34. dodoc -r example/*
  35. fi
  36. }
  37. pkg_postinst() {
  38. fdo-mime_desktop_database_update
  39. }
  40. pkg_postrm() {
  41. fdo-mime_desktop_database_update
  42. }