xnec2c-3.5.ebuild 717 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="A GTK+ graphical interactive version of nec2c"
  6. HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
  7. SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="doc examples"
  12. RDEPEND="dev-libs/glib:2
  13. x11-libs/gtk+:2"
  14. DEPEND="${RDEPEND}
  15. sys-devel/gettext"
  16. src_prepare() {
  17. glib-gettextize --force --copy || die
  18. eautoreconf
  19. }
  20. src_install() {
  21. default
  22. dodoc AUTHORS README doc/*.txt
  23. use doc && dohtml -r doc/*.html doc/images
  24. insinto /usr/share/doc/${PF}/examples
  25. use examples && doins examples/*
  26. }