osm2pgsql-0.88.1.ebuild 738 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # Tries to connect to local postgres server and other shenanigans
  5. RESTRICT="test"
  6. inherit autotools
  7. DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
  8. HOMEPAGE="http://wiki.openstreetmap.org/wiki/Osm2pgsql"
  9. SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="+lua +pbf"
  14. DEPEND="
  15. app-arch/bzip2
  16. dev-db/postgresql:=
  17. dev-libs/libxml2:2
  18. dev-libs/boost
  19. <sci-libs/geos-3.6.0
  20. sci-libs/proj
  21. sys-libs/zlib
  22. lua? ( dev-lang/lua:= )
  23. pbf? ( dev-libs/protobuf-c )
  24. "
  25. RDEPEND="${DEPEND}"
  26. src_prepare() {
  27. eautoreconf
  28. }