osm2pgsql-99999999.ebuild 828 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils git-r3
  5. EGIT_REPO_URI="git://github.com/openstreetmap/osm2pgsql.git"
  6. DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
  7. HOMEPAGE="http://wiki.openstreetmap.org/wiki/Osm2pgsql"
  8. SRC_URI=""
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS=""
  12. IUSE="+lua"
  13. DEPEND="
  14. app-arch/bzip2
  15. dev-db/postgresql:=
  16. dev-libs/expat
  17. <sci-libs/geos-3.6.0
  18. sci-libs/proj
  19. sys-libs/zlib
  20. lua? ( dev-lang/lua:= )
  21. "
  22. DEPEND="${COMMON_DEPEND}
  23. dev-libs/boost
  24. "
  25. RDEPEND="${COMMON_DEPEND}
  26. dev-db/postgis
  27. "
  28. # Tries to connect to local postgres server and other shenanigans
  29. RESTRICT="test"
  30. src_configure() {
  31. local mycmakeargs=(
  32. -DWITH_LUA=$(usex lua)
  33. -DBUILD_TESTS=OFF
  34. )
  35. cmake-utils_src_configure
  36. }