tilecache-2.11-r1.ebuild 597 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. DESCRIPTION="Web map tile caching system"
  7. HOMEPAGE="http://tilecache.org/"
  8. SRC_URI="http://${PN}.org/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="dev-python/pillow
  14. dev-python/paste"
  15. DEPEND="${RDEPEND}
  16. dev-python/setuptools
  17. "
  18. PATCHES=( "${FILESDIR}/tilecache-2.11-pil.patch" )
  19. src_install() {
  20. distutils-r1_src_install "--debian"
  21. }
  22. python_test() {
  23. python setup.py test || die "Failed tests"
  24. }