12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit autotools eutils fortran-2 toolchain-funcs
- MY_P="${PN}-ng_${PV}"
- DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
- HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ http://forge.scilab.org/index.php/p/arpack-ng/"
- SRC_URI="
- https://github.com/opencollab/${PN}-ng/archive/${PV}.tar.gz -> ${P}.tar.gz
- doc? (
- http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
- http://www.caam.rice.edu/software/ARPACK/DOCS/tutorial.ps.gz )"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
- IUSE="doc examples mpi static-libs"
- RDEPEND="
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi[fortran] )"
- DEPEND="${RDEPEND}
- virtual/pkgconfig"
- S="${WORKDIR}/${PN}-ng-${PV}"
- src_prepare() {
- default
- eautoreconf
- }
- src_configure() {
- econf \
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
- --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
- $(use_enable mpi)
- }
- src_test() {
- cp "${S}"/TESTS/testA.mtx "${BUILD_DIR}"/TESTS || die
- default
- }
- src_install() {
- default
- dodoc DOCUMENTS/*.doc
- newdoc DOCUMENTS/README README.doc
- use doc && dodoc "${WORKDIR}"/*.ps
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r EXAMPLES
- if use mpi; then
- insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
- doins -r PARPACK/EXAMPLES/MPI
- fi
- fi
- }
|